В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Maaaarrr
Maaaarrr
13.03.2020 00:44 •  Информатика

Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В. С (где число В равно 19, число А на 1 меньше числа В и число С на 1 больше числа В). Если их сумма четное число, то найдите и выведите на экран их произведение. Иначе, выведите на экран квадраты этих чисел в порядке возрастания. Выполнить в PascalABC.

Ответ:
ryure146
ryure146
05.07.2021 17:50

var

 a,b,c:integer;

begin

readln(a,b,c);

if (a+b+c)mod 2 = 0 then

 writeln(a*b*c)

   else

    writeln(sqr(a),' ',sqr(b),' ',sqr(c));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?