В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
terehovakira
terehovakira
16.02.2021 16:30 •  Информатика

Напишите программу, которая по введенному целому числу а (0≤ а ≤ 999999) находит сумму цифр этого числа s.

Ответ:
89286163503
89286163503
23.06.2020 17:54
Var a,col:integer;
s:string;
begin
readln(a);
if (a<0) OR (a>999999) then
writeln('Число А не соответствует условию')
else
begin
s:=IntToStr(a);//Переводим из числовой в строковую величину
col:=length(s);
writeln('Количество: ',col);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?