В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ксюш4
ксюш4
09.12.2021 06:51 •  Информатика

Задача по C++: Дан набор из N вещественных чисел Xk. Напишите программу,

рассчитывающую количество элементов, попадающих на отрезок

[AB], то есть удовлетворяющих условию A  Xk  B , где А и В – заданные вещественные числа.


Задача по C++: Дан набор из N вещественных чисел Xk. Напишите программу,рассчитывающую количество эл

Ответ:
Дуся003
Дуся003
04.07.2021 09:04

#include <iostream>

using namespace std;

class Set {

   int N, counter = 0;

   float A, B;

public:

   Set(int N, float A, float B) {

       this->N = N;

       this->A = A;

       this->B = B;

   }

   void Count() {

       for (int i = 0; i < N; i++) {

           float x;

           cin >> x;

           if (A <= x && x <= B)

               counter++;

       }

       cout << "Count = " << counter << endl;

   }

};

signed main()

{

   setlocale(LC_ALL, "Rus");

   int N;

   float A, B;

   cout << "Введите число элементов: (N) ";

   cin >> N;

   cout << "\nВведите числа A и B: ";

   cin >> A >> B;

   Set m(N, A, B);

   m.Count();

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?