В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nastlerfight
Nastlerfight
18.03.2023 12:57 •  Информатика

Найти количество отрицательных элементов в каждой строке массива MxN, заполненного случайными числами от -25 до 25 Входные данные:
Количество строк: 4
Количество столбов: 5
Паскаль.

Ответ:
123123ilya
123123ilya
02.07.2021 10:09

Free Pascal

var

 a : array of array of integer;

 b : array of integer;

 s, i, j, n, m : integer;

begin

 writeln('Введите кол-во строк:');

 readln(m);

 writeln('Введите кол-во столбцов:');

 readln(n);

 randomize;

 setlength(a, n);

 setlength(b, m);

 for i:=0 to n-1 do

   setlength(a[i], m);

 for j:=0 to m-1 do begin

   s:=0;

   for i:=0 to n-1 do begin

     a[i,j] := random(50) - 25;

     if a[i,j] <0 then inc(s);

     write(a[i, j], '  ');

   end;

   b[j]:=s;

   writeln();

 end;

 writeln('--------------------------');

 for j:=0 to m-1 do

   writeln(j+1,' строка = ', b[j]);

end.


Найти количество отрицательных элементов в каждой строке массива MxN, заполненного случайными числам
0,0(0 оценок)
Ответ:
superfrap320
superfrap320
02.07.2021 10:09

##

var n := ReadInteger;

var a := ArrRandom(n, -28, 27);

a.Println.Where(t -> t.Divs(3)).Product.Print


Найти количество отрицательных элементов в каждой строке массива MxN, заполненного случайными числам
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?