В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ruda05
Ruda05
27.01.2022 00:48 •  Информатика

Напишите программу (паскаль): выводится 5 строк, в которых сначала записан порядковый номер строки с точкой, а затем слово. вывести слова в алфавитном порядке. например : 1.информатика 2. 3. 4.физкультура 5. вывод: 1.информатика 5. 3. 4.физкультура 2.

Ответ:
ogurtsov2001
ogurtsov2001
23.06.2020 17:30
Uses crt;
const n=5;
var    
s:array[1..n] of string; 
  i,j,c:integer; 
  ss:string;
begin
writeln('Введите :');
for i:=1 to n do begin 
 write('s[',i,']='); 
 readln(s[i]);                       
 end;
for i:=1 to n-1 do
for j:=i+1 to n do
if s[i]>s[j] then 
begin 
 ss:=s[i]; 
 s[i]:=s[j]; 
 s[j]:=ss; 
end;
 for i:=1 to n do
writeln(i,'.',s[i],'  ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?