В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Anna111864
Anna111864
24.03.2022 17:53 •  Информатика

Написать программу, вычисляющую стоимость покупки с учётом скидки: куплено 4 товара, если сумма превышает 2500р, то скидка составит 5%, если превышает 1300р, то скидка составит 3%​. Нарисовать блок-схему. Язык: Паскаль​

Ответ:
герман123344444
герман123344444
30.05.2021 14:50

var

summa, skidka: real;

begin

writeln('Вычисление стоимости покупки с учетом скидки.');

writeln('Введите сумму покупки: ');

readln(summa);

 if summa >= 1300 then skidka:=3

  else if summa > 2500 then skidka:=5

   else if summa < 1300 then skidka:=0;

writeln('Вам предоставлена скидка ', skidka, '%');

writeln('Сумма покупки с учетом скидки: ', (summa-(summa*skidka)/100));

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?