В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Amshvd
Amshvd
17.08.2022 12:37 •  Информатика

САМОЕ ГЛАВНОЕ! Через цикл While! Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 6. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0. В последовательности всегда имеется число, оканчивающееся на 6. Введённые числа не превышают 30 000. Программа должна вывести одно число —минимальное число, оканчивающееся на 6.

Ответ:
polinacavina
polinacavina
29.06.2021 12:00

c++

#include <iostream>

using namespace std;

int main()

{

   int x = 1, min = 99999;

   while(x){

       cin >> x;

       if(x % 10 == 6 && x < min) min = x;

   }

   cout << min;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?