В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Anyta31107
Anyta31107
24.09.2022 14:12 •  Информатика

Программирование (Питон ,
Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. (Питон)
Числа вводятся через input, а также, для последовательности, нужен цикл for

Ответ:
алиная2
алиная2
25.06.2021 06:32

Python

n=int(input('Введите количество чисел : '))

a=[0]*n

for i in range(n):

   a[i]=int(input('a['+str(i)+']='))

z=999999

for i in a:

   if z>i and i%2==0:

       z=i

if z!=999999:

   print('минимальное чётное число=', z)

else:

   print('Чётных чисел не найдено')

# 2 вариант с использованием sorted    

n=int(input('Введите количество чисел : '))

a=[0]*n

for i in range(n):

   a[i]=int(input('a['+str(i)+']='))

a=sorted(a)

for i in a:

   if i%2==0:

       print('минимальное чётное число=', i)

       break

   


Программирование (Питон , Напишите программу, которая в последовательности натуральных чисел опреде
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?