В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Даниил5356
Даниил5356
04.06.2023 19:53 •  Информатика

Вот условия задачи: составить программу расчёта значения функции

Z=(x-2*ctg*2y)/{8x-5 arctg y}

вот код

program tri;

var x,y,z:real;

begin

writeln('Введите x, Введите y');

read(x,y);

z:=(x-2*cos(x)/sin(x)*2*y)/{8*x-5*arctan(1/x)*y}

writeln('При x = ', x , ' y = ', y, ' z = ', z:6:2 );

readln(x,y);

end.

Пишет ошибку Program1.pas(7) : Ожидалась функция, встречена процедура Writeln
ПАСКАЛЬ

Ответ:
superstudio57
superstudio57
26.05.2021 06:00

Объяснение:

z:=(x-2*cos(x)/sin(x)*2*y)/{8*x-5*arctan(1/x)*y}

6-ю строчку переделать.

Вот так должно быть :

z:=(x-2*cos(x)/sin(x)*2*y)/(8*x-5*arctan(1/x)*y);

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?