В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
masha3500
masha3500
06.08.2022 21:17 •  Информатика

Написать программу для решения следующей : вычислить сумму и количество положительных элементов последовательности.

Ответ:
nikitachymev
nikitachymev
01.10.2020 12:22
Var
  sum, count, t : integer;
begin
  sum := 0; count := 0;
  while not eoln do
  begin
    read (t);
    if t > 0 then
    begin
      sum := sum + t;
      count := count + 1;
    end;
  writeln (sum, ' ', count);
end.

если количество элементов указано
var
  sum, count, t, n, i : integer;
begin
  sum := 0; count := 0;
  read (n);
  for i := 1 to n do 
  begin
    read (t);
    if t > 0 then
    begin
      sum := sum + t;
      count := count + 1;
    end;
  writeln (sum, ' ', count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?