В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nodar2004
Nodar2004
13.12.2020 04:02 •  Информатика

Склавиатуры вводится строка. с новой строки вводится буква. составьте программу подсчета количества заданных букв в заданной строке. определить, является ли длина введенного слова числом, кратным трем. определить, заканчивается ли введенное слово гласной буквой.

Ответ:
мама1021
мама1021
23.06.2020 15:42
Var
  s : string;
  c : char;
  i, a : integer;
begin
  readln (s);
  read (c);  
a := 0;
  for i := 1 to length(s) do if s[i] = c then a := a + 1;
  write (a);
end.

var
  s : string;
begin
  readln (s);
    if length (s) mod 3 = 0  then write ('YES') else write ('NO');
end.

var
  s : string;
begin
  readln (s);
    if s[length (s)] in ['а', 'о',тут через запятую гласные]  then write ('YES') else write ('NO');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?