Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Katenkalovely
16.07.2022 19:04 •
Информатика
Взаданном одномерном массиве поменять местами соседние элементы. напишите программу на паскале, заранее !
Ответ:
Hskke
23.06.2020 14:49
Var
n, i, c : integer;
a : array [1..1000] of integer;
begin
read (n);
for i := 1 to n do read (a[i]);
for i := 1 to n div 2 do
begin
c := a[i*2];
a[i*2] := a[i*2-1];
a[i*2-1] := c;
end;
for i := 1 to n do
write (a[i], ' ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
MiaRia123
18.02.2021 19:17
Дан массив 10 целых чисел. найти сумму элементов массива, кратных числу n (вводится с клавиатуры)....
notmedont
29.12.2021 05:03
Реферат учащегося по информатике имеет объём 21 кбайт. каждая страница реферата содержит 32 строки по 64 символа в строке, мощность алфавита- 128. сколько страниц в реферате?...
Lizzza1111
21.07.2022 22:43
Решить на ! передавая записку на уроке языка, друзья не хотят, чтобы кто-то прочел ее содержимое. для этого текст шифруют простым методом: заменяют каждую букву на букву,...
Роли5
23.08.2021 06:03
F = A&B V (A&B). постройке таблицу истинности логического выражения...
makar32ryc
27.09.2022 23:50
Расскажите про операции над множествами и таблицы истиности для основных логических операций...
nikita011278923
13.01.2021 05:15
Дана программа на языке паскаль. программа определения весовой категории в зависимости от веса спортсмена. если вес спортсмена меньше 69, то «лёгкая категория» иначе...
riabinova19
08.01.2020 14:46
Виюне за водоснабжение заплатили 2500 руб. а в июле - на 20% меньше. на сколько рублей меньше заплатили в июле чем в июне?...
nikaaleksievich
14.11.2021 19:43
Аня написала несколько различных натуральных чисел, не больших 100 таких, что ни сумма, ни произведение никаких двух различных чисел не делится на 100. какое наибольшее...
misha515
23.06.2022 16:44
Укажите номер правильного ответа 1) фигура, изображена на рисунке, это шестиугольник ...
hotengel
17.10.2020 15:21
Paris est la capitale de la france. c’est une ville très ancienne. ella a plus de deux mille ans. la ville est située sur la seine qui la divise en deux parties: la rive...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n, i, c : integer;
a : array [1..1000] of integer;
begin
read (n);
for i := 1 to n do read (a[i]);
for i := 1 to n div 2 do
begin
c := a[i*2];
a[i*2] := a[i*2-1];
a[i*2-1] := c;
end;
for i := 1 to n do
write (a[i], ' ');
end.