В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mikkie3
mikkie3
17.06.2022 04:48 •  Информатика

Вы ввели трехзначное число. затем ввели любое число а. составьте программу, определяющую, равна ли сумма цифр числа задоному числу а контруха по инфе

Ответ:
medlitelnaj
medlitelnaj
23.06.2020 03:57
Var a, b, c, i: integer;
    d: string;
begin
     readln(a, b); 
     d := inttostr(a);
     for i := 1 to length(d) do
         c := c + strtoint(d[i]);
     if (b = c) then writeln('Yes') else writeln('No');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?