В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ksusha2311021
ksusha2311021
18.08.2022 06:45 •  Информатика

Написать программу в pascalabc.net задано натуральное число .напишите программу ,которая для число с нечётным количеством цифр выведет на экран цифру , стоящую на средней позиции числа .

Ответ:
tanakovalizka1
tanakovalizka1
07.06.2020 00:05

var

 x, a, k, t, i, d: integer;

begin

 readln(x);

 a := x; k := 0;

 while a > 0 do

 begin

   k += 1;

   a := a div 10;

 end;

 if k mod 2 = 0 then

   write('В числе четное количество цифр')

 else

 begin

   t := 1;

   for i:=1 to k div 2 do

     t *= 10;

   d := x div t mod 10;

   write(d);

 end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?