В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
antonkovalenko1
antonkovalenko1
07.11.2020 11:15 •  Информатика

По программированию на с++ с использованием оператора while () написать программу, которая будет выводить на экран: «введи многозначное число», затем считывать введенное с клавиатуры целое число, считать количество цифр и выводить на экран корректную фразу: «в числе ! число! ! результат! цифра/цифры/цифр»

Ответ:
kocheryan86p08jni
kocheryan86p08jni
01.10.2020 12:06

Объяснение:

#include "pch.h"

#include <stdio.h>

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

setlocale(LC_ALL, "Russian");

int num, k=0;

string str;

cout << "Введи многозначное число" << endl;

cin >> num;

while (num != 0)

{

 k += 1;

 num /= 10;

}

if(k==1)

{

 cout << k << " цифра" << endl;

}

else if (k >= 2 && k <= 4) {

 cout << k << " цифры" << endl;

}

else {

 cout << k << " цифр" << endl;

}

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?