В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от -10 до 25. программа должна: 1)выводить на экран сначала все элементы массива, стоящие на чётных местах, а затем - все элементы массива, стоящие на нечётных местах; 2)вывести на экран сумму всех элементов массива, значение которых кратны 3 или 5. 3)найти минимальное значение и максимальное значение элементов массива.

Ответ:
здравствуйте112
здравствуйте112
23.06.2020 00:07
Program x;
const n = 20;
var a: array [1..n] of integer;
s,max,min: integer;
begin
Randomize;
for i:=1 to n do
 a[i]:= Random(35) - 15;
for i:=1 to n do
 if i mod 2 = 0 then
  write(a[i]);
writeln;
for i:=1 to n do
 if i mod 2 <> 0 then
 write(a[i]);
writeln; s:=0;
for i:= 1 to n do
 if (a[i] mod 3 = 0) or (a[i] mod 5 = 0) then
  s:= s+a[i];
writeln(s); max:= -15; min:= 20;
for i:=1 to n do
begin
 if a[i] > max  then max:= a[i];
if a[i] < min then min:= a[i];
end;

writeln(max, min);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?