В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Pascalabc.net , решите используя только: int64, begin, var, for, if, end. больше добавлять переменных не надо. 98 теперь, когда торговля в городе процветает, пришло время подумать о перспективах. в вашу казну недавно пришло n поступлений по k сентиннеалей. вы решили инвестировать их в промышленность и рассчитываете на ежегодное увеличение своего вложения в m раз. рассчитайте, сколько сентиннеалей у вас будет через х лет. формат входных данных в первой строке вводится целое число денежных поступлений n (1 < = n < = 100) во второй строке вводится n целых чисел k в строчку, где k - каждое из постулений (1< = k < =10000) в третьей строке вводятся целые числа x и m - количество лет, в течении которых будет накапливаться итоговая сумма (1< = x < =10), и число раз, в которые будет увеличиваться сумма каждый год (2< = m < =12) формат выходных данных выводится целое число, равное итоговой сумме накоплений. примеры входные данные 5 2 2 5 4 2 1 2 выходные данные 30

Ответ:
vadimfarxudinov
vadimfarxudinov
24.05.2020 19:30

var

   n, k, x, m: int64;

begin

   readln(n);

   for x := 1 to n do begin

       read(k);

       n += k-1;

   end;

   readln(x, m);

   writeln(n*x*m);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?