В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ksu1976reg
ksu1976reg
14.03.2022 11:39 •  Информатика

70 . дан целочисленный массив из 30 элементов заданный случайным образом. элементы массива могут принимать целые значения от -30 до +30 - значение среднесуточной температуры для каждого из 30 дней некоторого месяца. составьте программу, которая позволяет найти и вывести количество дней этого месяца, температура для которых была выше, чем температура в предыдущий день этого же месяца. паскаль. (там var, array, integer или тип того)

Ответ:
ProPython
ProPython
24.05.2020 19:30

const n=30;

var a:array[1..n] of integer;

i,k:integer;

begin

randomize;

writeln('Исходный массив:');

for i:=1 to n do

begin

a[i]:=random(61)-30;

write(a[i],' ');

end;

writeln;

k:=0;

for i:=2 to n do

if a[i] > a[i-1] then k:=k+1;

writeln('k = ',k);

end.

Пример:

Исходный массив:

27 -16 19 23 12 3 25 6 -3 -22 12 13 22 -8 -3 7 -1 -20 -28 -20 25 22 13 -8 -3 -17 14 22 11 -9  

k = 13

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?