В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dankorolckov20
dankorolckov20
05.01.2022 07:09 •  Информатика

Написать программу в delphi 7, содержащую цикл для вычисления функции если n=10, a0=0.75, a1=1.6, a2=a3==a10=2.0; x изменяется с шагом h=0.2 от x1=0 дo x2=2.0.

Ответ:
aruukealtymysh
aruukealtymysh
01.10.2020 12:00
Const
  a: array[1..11] of real = (0.75, 1.6, 2, 2, 2, 2, 2, 2, 2, 2, 2);

var
  x, h, x1, x2: real;

function F(x: real): real;
var
  i: integer;
  x_n, res : real;
begin
  res := a[1];
  x_n := 1;
  for i := 1 to 10 do
  begin
    x_n := x_n * x;
    res := res + a[i + 1] * x_n;
  end;
  F := res;
end;

begin
  x1 := 0; x2 := 2;
  h := 0.2;
  x := x1;
  repeat
    writeln('x = ', x:3:1, '  y = ', F(x):9:3);
    x := x + h;
  until x > x2;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?