В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Анют2006
Анют2006
21.03.2020 03:20 •  Информатика

Сформируйте одномерный массив из n-элементов (значения элементов зависит от порядкового номера массива и вычисляется по формуле ( i+5)^2). параметр n должен задавать пользователь. напишите программу, вычисляющую сумму значений элементов одномерного массива и среднее арифметическое введенных n чисел. вывод оформите в строку через пробел.

Ответ:
axmefibragimovp09v94
axmefibragimovp09v94
22.06.2020 17:19
Var
  a: array[1..100] of integer;
  i, s, n: integer;
begin
  readln(n);
  for i := 1 to n do begin
    a[i] := (i + 5) * (i + 5);
    write(a[i],' ');
    s := s + a[i];
  end;
  writeln;
  writeln(s, ' ', s / n);
end.
0,0(0 оценок)
Ответ:
DVOECHNIK225
DVOECHNIK225
22.06.2020 17:19
Uses crt;
const m=1000;
var a:array[1..m] of integer;
i,s,n:integer;
sr:real;
begin
readln(n);
writeln;
s:=0;
for i:=1 to n do
begin
a[i]:=(i+5)*(i+5);
writeln(a[i]);
s:=s+a[i];
end;
writeln;
sr:=s/n;
writeln(s,' ',sr);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?