В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
илья1968
илья1968
05.06.2021 04:01 •  Информатика

Дан массив из 30-ти элементов. каждый элемент может принимать целочисленные значения от -100 до 100. напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. qbasic

Ответ:
plekhanov04
plekhanov04
22.06.2020 15:00
Искренне надеюсь, что Вы сможете перевести этот код к нужному виду..:) В принципе, расхождения должны быть только в вводе/выводе (где Console.Бла-бла-бла) и генерации случайных чисел)

Sub Main()
        Dim a(29), Sum, Col As Integer
        Dim Rnd = New Random()
        For i As Integer = 0 To 29
            a(i) = Rnd.Next(-100, 100)
            Console.Write("{0} => {1}" + Environment.NewLine, i, a(i))
            If (i > 0) Then
                If (a(i) Mod a(0)) Then
                    Sum = Sum + a(i)
                    Col = Col + 1
                End If
            End If
        Next
        Console.WriteLine(Math.Round(Sum / Col, 2))
        Console.ReadKey()
    End Sub
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?