В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Викуха4А
Викуха4А
14.05.2022 22:02 •  Информатика

Написать программу для: 1. определите есть ли в данном массиве отрицательные элементы 2. есть ли два одинаковых элемента 3. есть ли данное число в среди элементов массива вы мне , заранее!

Ответ:
konobeevvlad
konobeevvlad
22.06.2020 14:37
Написано в Pascal:

Program Zadacha;
Const n = 10;
Var a: Array [1..n] of Integer;
B, c, i, j: Integer;
d, e: Boolean;
Begin
WriteLn('Введите ', n, ' целых чисел через пробел и нажмите Enter');
For i := 1 To n Do
Read(a[i]);
Write('B = ');
ReadLn(B);
c := 0;
For i := 1 To n Do
If a[i] < 0 Then
c := c + 1;
WriteLn('Количество отрицательных элементов массива равно ', c);
d := False;
For i := 1 To n Do
Begin
c := a[i];
For j := i + 1 To n Do
If c = a[j] Then
d := True;
End;
If d = True Then
WriteLn('В массиве есть одинаковые элементы')
Else
WriteLn('В массиве нет одинаковых элементов');
e := False;
For i := 1 To n Do
If a[i] = B Then
e := True;
If e = True Then
WriteLn('В массиве есть элемент, равный ', B)
Else
WriteLn('В массиве нет элемента, равного ', B);
ReadLn;
End.
0,0(0 оценок)
Ответ:
dedada
dedada
22.06.2020 14:37
Язык Python

A = [1,2,3,4,5,6] # Массив
B = 10

# 1 Задание
A.sort()
if A[0]<0:
  print "Есть отрицательные элементы"
else:
  print "Отрицательных элементов нет"
# 2 задание
cnt = len(A)
for i in A:
  if A.count(i)>1:
    print "Есть повторяющиеся элементы"
    break
  cnt-=1
if not cnt:
  print "Повторяющихся элементов нет"
# 3 задание
if B in A:
  print "В входит в массив"
else:
  print "В не входит в массив"
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?