В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alinochkaderyu
alinochkaderyu
24.05.2023 00:37 •  Информатика

Нужно написать программу в паскале дан механизм,состоящий из двух шестеренок. у одной шестеренки n зубцов,у другой k. требуется найти какое минимальное число поворотов на один зубчик требуется сделать,чтобы шестеренки вернулись в исходное состояние.

Ответ:
sucker046
sucker046
22.06.2020 14:08
Program task;
var i,n,k:longint;
begin     
writeln('n?');     
readln(n);     
writeln('k?');     
readln(k);     
for i:=1 to n*k do begin       
if ((i mod n = 0) and (i mod k = 0)) then begin         
writeln(i);         
break;       
end;     
end;     
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?