В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Qurin
Qurin
08.03.2022 13:57 •  Информатика

Составить программу, которая определяет, являются ли разные точки с координатами (x1,y1) и (x2, y2) симметричными относительно осей координат или начала координат. программу составить двумя с использованием составных условий. без использование составных условий. проверить правильность программ для следующих значений параметров: а) x1= -1, y1=6, x2=1, y2=6. б) x1=6, y1=7, x2=1, y2=6.

Ответ:
abobov1234
abobov1234
22.06.2020 13:40
А на языке каком нужно написать си или паскаль ?
0,0(0 оценок)
Ответ:
МаксVFRCBV
МаксVFRCBV
22.06.2020 13:40
С использованием составных условий:

Program Type1;
Var X1, Y1, X2, Y2: Integer;
BeginWriteLn('X1 = ');
ReadLn(X1);
WriteLn('Y1 = ');
ReadLn(Y1);
WriteLn('X2 = ');
ReadLn(X2);
WriteLn('Y2 = ');
ReadLn(Y2);
If (X1 = -X2) And (Y1 = -Y2) Then
WriteLn('Точки симметричны относительно начала координат')
Else If (X1 = -X2) And (Y1 = Y2) Then
WriteLn('Точки симметричны относительно оси Y')
Else If (X1 = X2) And (Y1 = -Y2) Then
WriteLn('Точки симметричны относительно оси X')
Else
WriteLn('Точки не симметричны');
ReadLn;
End.

Без использования составных условий:

Program Type2;
Var X1, Y1, X2, Y2: Integer;
Begin
WriteLn('X1 = ');
ReadLn(X1);
WriteLn('Y1 = ');
ReadLn(Y1);
WriteLn('X2 = ');
ReadLn(X2);
WriteLn('Y2 = ');
ReadLn(Y2);
If (X1 + X2 = 0) And (Y1 + Y2 = 0) Then
WriteLn('Точки симметричны относительно начала координат')
Else If (X1 + X2 = 0) And (Abs(Y1) - Abs(Y2) = 0) Then
WriteLn('Точки симметричны относительно оси Y')
Else If (Abs(X1) - Abs(X2) = 0) And (Y1 + Y2 = 0) Then
WriteLn('Точки симметричны относительно оси X')
Else
WriteLn('Точки не симметричны');
ReadLn;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?