В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ryslan3222
ryslan3222
09.05.2023 22:58 •  Информатика

Составить программувысота сосны в начале года 1.8 м, а к концу года она увеличилась на 15%. какая будет высота через "n" лет, если ее прирост за каждый следующий год= 90 % от прироста предыдущего

Ответ:
MrFoxTv
MrFoxTv
22.06.2020 11:16
Program first;
var a,b:real; n:integer;
begin
readln(n);
if n=0 then begin
writeln('Сосна почти не выросла за этот промежуток времени');
exit;
a:=1,8;
b:=(1,8*15)/100;
for i:=1 to n-1 do
b:=b+((b*90)/100);
writeln('Висота сосны через ',n,' лет равна', a+b);
end.
0,0(0 оценок)
Ответ:
ишришощизть
ишришощизть
22.06.2020 11:16
Написано на Pascal:

Program Sosna;
Var a, b: Real;
n, i: Integer;
Begin
a := 1.8;
Write('n = ');
ReadLn(n);
b := a * 0.15;
a := a + b;
For i := 1 To n Do
Begin
b := b * 0.9;
a := a + b;
End;
WriteLn('Высота сосны через ', n,' лет будет ', a:10:2, ' м.');
ReadLn;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?