В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Pomogatorr
Pomogatorr
24.10.2020 19:26 •  Информатика

Составить программу в паскале для 8 класса, без array , : найти кол-во четных цифр числа, тема - разработка алгоритма содержащего цикл с условием, тоесть с while, do, begin ну тоесть их испобьзовать, вот так составить программу по

Ответ:
Kseniakool
Kseniakool
22.06.2020 11:14
Самое простое что придумал)))
uses crt;
var
i,a,s:integer;
begin
write('vvedite 4islo: ');
read(a);
s:=0;
while a>=1 do
begini:=a mod 10;
a:=a div 10;
if i mod 2=0 then
s:=s+1;
end;
write('kolvo 4etnblx=',s);
read;
end.
смысл программы:делит число на 10 и проверят четный остаток или нет, и следовательно четная это была цифра или нет)))
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?