Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
dimanichaev799
08.07.2021 17:33 •
Информатика
Дан массив a(m), m ≤ 20.найти сумму s его положительных элементов. все отрицательные элементы удвоить. вывести на печать исходный массив, переформированный массив и число s.
Ответ:
VitaVita2003
22.06.2020 07:32
For i:=1 to m do
begin
if (-a[m]<>a[m]) then s:=s+1;
else a[m]:=a[m]*2;
writeln(a[m],' ');
end;
writeln(s);
0,0
(0 оценок)
Популярные вопросы: Информатика
gangsta288
23.11.2021 05:04
Выразите 8965921 бит в мб . решение оформите в виде цепочки ....
VERAVERAVERAVERA123
10.01.2022 20:07
Решите паскаль: ((a+b)c)d=x a=5 b=4 c=6 d=8...
лилькп
10.01.2022 20:07
Придумать рифму на два джинтельмена...
Reek5657
10.01.2022 20:07
❤сканируется цветное изображение размером 10 х 15 см. разрешающая сканера - 600 х 600 dpi, глубина цвета - 3 байта. какой информационный объём будет иметь полученный графический...
illay0409
10.01.2022 20:07
Какое значение будет принимать переменная у после выполнения программы: var x, y: integer; begin y: =1 ; x: =15 repeat y: =y*x; x: =x-3 until x 5; writeln ( y= ,y); end x y...
mikstura71
10.01.2022 20:07
Разгадайте кроссворд инструменты графичесеого редактора...
Maxguvci
10.01.2022 20:07
Напишите программу. 1). дан радиус шара. найти его объём. 2). даны стороны треугольника: a,b,c. вычислить косинусы углов по теореме косинусов. 3). опредедить, сколько полных...
sashkaaaxo
16.08.2022 21:55
Дано два числа . если числа положительны , то уменьшите их на 2 . если числа отрицательны , то увеличить их на 2 . если первое положительное , а второе отрицательно , то найти...
dan362
16.08.2022 21:55
Вы хотите работать с разрешением монитора 1600x1200 пикселей , используя 16 777 216 цветов .в магазине видеокарты с памятью 512 мбайт , 2 мбайт , 4 мбайт , и 64 мбайт . какую...
nastasyasaenko
16.08.2022 21:55
Расчитайте обьем видеопамять, необходимой для хранения графического изображения, занимающего весь экран манитора с расширением 1024x768 и количеством отображаемых цветов,равным...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
if (-a[m]<>a[m]) then s:=s+1;
else a[m]:=a[m]*2;
writeln(a[m],' ');
end;
writeln(s);