В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
кирилл2122
кирилл2122
19.08.2022 00:53 •  Информатика

Напишите программу на паскале, которая в двумерном массиве находит самое большое значение и элементы строки и столбца, на пересечении которых он стоит, делает нулевыми. я начал решать, нашел максимальное значение в массиве, а вот дальше что-то не понял. возьмите кол-во столбцов и строк по 5. заранее. : )

Ответ:
PlayGirl1999
PlayGirl1999
22.06.2020 06:53
Var max_i, max_j, j, columns, rows, i : integer;
arr: array[1..10,1..10] of integer;
Begin
  rows := random(8) + 2;
  columns := random(8) + 2;
  writeln(rows, columns);
 
  for i := 1 to rows do
    for j := 1 to columns do
      arr[i, j] := random(100);

  for i := 1 to rows do begin
    writeln();
    for j := 1 to columns do
      write(arr[i, j]:3);
  end;
  writeln();
  writeln();

  max_i:=1;
  max_j:=1;

  for i := 1 to rows do
    for j := 1 to columns do
      if arr[max_i, max_j] < arr[i, j] then begin
        max_i:=i;
        max_j:=j;
      end;

  for i := 1 to rows do
    if i <> max_i then
      arr[i, max_j] := 0;

  for j := 1 to columns do
    if j <> max_j then
      arr[max_i, j] := 0;

  for i := 1 to rows do begin
    writeln();
    for j := 1 to columns do
      write(arr[i, j]:3);
  end;
  writeln();
  writeln();
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?