В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
gels5344Inetka
gels5344Inetka
14.04.2022 00:29 •  Информатика

По программированию на с++ с использованием оператора for () написать программу, которая будет выводить на экран: «введи размерность», затем считывать введенное с клавиатуры целое число и выводить на экран таблицу умножения вида: (если введено 3) 1 2 3 1 1 2 3 2 2 4 6 3 3 6 9

Ответ:
nsalexandrovna
nsalexandrovna
22.06.2020 06:38

#include <iostream>

using namespace std;

int main(){

setlocale(LC_ALL, "Russian");

int a;

cout<<"Введи размерность"<<endl;

cin>>a;

int arr[a+1][a+1];

for (int i=1; i<a+1; ++i)

 for(int j=1; j<a+1; ++j)

  arr[i][j]=i*j;

for (int i=1; i<a+1; ++i) {arr[i][0]=i;arr[0][i]=i;}

cout<<"  ";

for (int i=1; i<a+1; ++i){cout<<arr[i][0]<<" ";}

cout<<endl;

for (int i=1; i<a+1; ++i){

 for(int j=0; j<a+1; ++j)

  cout<<arr[i][j]<<" ";

 cout<<endl;

}

return 0;

}

Т.к. в условии про оформление ничего не сказано, то сделал самое обычное

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?