В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ladyhyuna
ladyhyuna
27.05.2021 16:18 •  Информатика

1. составьте программу для определения суммы денег, получаемой авиакомпанией от продажи билетов на рейс из лондона в нью-йорк, если в самолете три четверти пассажиров имеют билеты первого класса, стоимостью х рублей за каждый. остальные пассажиры имеют билеты второго класса, которые дешевле на 20% 2.составьте программу определения стоимости набора конфет, в которой находятся следущие сорта: наименование: количество: цена,руб: красная шапочка 500 г k алые паруса 200 г a воронежские 100 г b чародейка 250 г m

Ответ:
илья1949
илья1949
22.06.2020 06:27
Program avia;
uses crt;
var
p:integer;
s,s2,pr,ch3:real;
begin
writeln('Стоимость билета 1 класса: ');
read(s);
writeln('Общее количество пассажиров: ');
read(p);
ch3:=(3*(p/4));// 3 четверти пассажиров
pr:=(s/100)*20;// 20% от стоимости
s2:=(ch3*s)+((p/4)*pr);
writeln('Всего заработает за рейс: ',s2);
end.

program cena;
uses crt;
var
k,a,b,m,obc:real;
begin
writeln('Цена за конфеты "Красная шапочка": ');
read(k);
writeln('Цена за конфеты "Алые паруса": ');
read(a);
writeln('Цена за конфеты "Воронежские": ');
read(b);
writeln('Цена за конфеты "Чародейка": ');
read(m);

 obc:=0.5*k+0.2*a+0.1*b+0.25*m;
 writeln('Всего ',obc,' руб.')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?