В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alikrufgffgfgf
alikrufgffgfgf
26.08.2022 10:20 •  Информатика

Составить программу. -сформулируйте и выведите на экран массив из 9 элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен квадрату текущего индекса, увеличенному на 5; 2-й равен целой части квадратного корня из предыдущего элемента; 3-й равен целой части от деления двух предыдущих элементов.

Ответ:
Дллллллллллл
Дллллллллллл
22.06.2020 00:55
Var
  i : integer;
  aa : array[1..9] of integer;

begin
  { высчитываем элементы массива }
  for i := 1 to 9 do
    if i mod 3 = 1 then
      aa[i] := (i + 5) * (i + 5)
    else if i mod 3 = 2 then
      aa[i] := round(sqrt(aa[i-1]))
    else
      aa[i] := aa[i-1] div aa[i-2];
  { выводим значения на экран }
  for i := 1 to 9 do
    write(aa[i], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?