В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составьте программу выводящую на экран числа от 1 до 30 которые делятся без остаткак на и на 3 но не делятся на 4

Ответ:
nfskarbon2
nfskarbon2
21.06.2020 16:13
Var a,b,c,n,i:integer;
begin
  writeln('На что должно делиться (2 числа через пробел) =>');
  readln(a,b); {делится на а и b  но не делится на c}
  writeln('На что не должно делиться (1 число) =>');
  readln(c);
  writeln('Верхняя граница(1 число) =>');
  readln(n);

  for i:= 1 to n do
   if (i mod a = 0) and (i mod b = 0) and (i mod c <> 0) then
       writeln(i);
end.

var i:integer;
begin
  for i:= 1 to 30 do
   if (i mod 2 = 0) and (i mod 3 = 0) and (i mod 4 <> 0) then
       writeln(i);
end

2)
var i:integer;
begin
 
  for i:= 50 downto 1 do
   if (i mod 2 <> 0) then
       writeln(i);
end.
0,0(0 оценок)
Ответ:
CHOCOдракошка
CHOCOдракошка
21.06.2020 16:13
1)
var
i: Integer;
begin
for i:=1 to 30 do
if ((i mod 2) = 0) and ((i mod 3) = 0) and ((i mod 4) <> 0) then
WriteLn(i);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?