Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
chvdima
20.02.2020 15:58 •
Информатика
Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20, и производит одно из следующих вычислений: сумму чисел,кратных 3
Ответ:
ilia113
21.06.2020 15:55
#include <stdio.h>
#include <conio.h>
#include <stdlib.h>
#include <ctime>
main()
{
int b=0,a[40],k=40,i;
srand(time(0));
for (i=0;i<k;i++){
a[i]=rand()% 21;
printf("%3d",a[i]);
}
for (i=0;i<k;i++){
if ((a[i]%3)==0){
b+=a[i];
}
}
printf("\n%d",b);
getch();
}
0,0
(0 оценок)
Популярные вопросы: Информатика
ТимурСилкин
21.01.2021 13:51
Определить, являются ли два логических высказывания x и y эквивалентными...
DesertTwo1
27.07.2020 18:25
Логическое выражение, используя законы равносильных преобразования....
alinademushkina1
29.03.2020 23:26
На моём аккаунте есть ещё 2 по типу таких)...
ivan70region
21.07.2020 04:45
4. Допишите программу, которая вывод самое большое число из 3 заданных чисел: Условне: даны 3 числа а, b и с. Вывести самое большое из них. a=int(input()) b=int(input())...
rasimrasivi
27.12.2020 15:05
Який тип даних в Access використовується для прикріплення файлів з різним умістом: зображення, електронні таблиці та інше? Аналогічно прикріпленню файлів до повідомлень...
dany20skribka
17.10.2021 13:42
Мова програмування: Пайтон Створіть програму для розв язання задачі: дівчинка зібрала k кошиків винограду вагою m кг n г у кошику та а кошиків вагою b кг c г у...
schooll2
12.05.2020 15:44
Отвечаем на вопросы 1. Как добавить звук в презентацию? 2. Как настроить звуки в презентации? Думаем и обсуждаем HE SINOQTOCH 1. Почему важно добавлять звуки и...
люба358
16.08.2020 19:51
Почему при высокой сейсмичности территории в горах южной сибири нет действующих вулканов?...
WERTO124
16.08.2020 19:51
Примеры в сффексах енн онн ин ян ан...
Nastyxas
16.08.2020 19:51
Найдите значение выражения 3 3/4 (2(целая) 4/7 -1(целая) 1/12)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <conio.h>
#include <stdlib.h>
#include <ctime>
main()
{
int b=0,a[40],k=40,i;
srand(time(0));
for (i=0;i<k;i++){
a[i]=rand()% 21;
printf("%3d",a[i]);
}
for (i=0;i<k;i++){
if ((a[i]%3)==0){
b+=a[i];
}
}
printf("\n%d",b);
getch();
}