В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
катя1377
катя1377
13.11.2022 02:59 •  Информатика

1)напишите программу формирования массива размеров 5 х 5 с датчика случайных чисел.замените в нем все четные значения элементов суммой индексов элементов главной диагонали.выведите на экран исходный и измененный массивы (программа на языке паскаля) 2)составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с датчика случайных чисел

Ответ:
алекс818
алекс818
21.06.2020 12:18
Var a: array [1..5, 1..5] of integer;
    i, m, j: integer;
begin
     for i := 1 to 5 do
         for j := 1 to 5 do
         begin
              a[i, j] := random(50) - 25;
              writeln('[', i, ',', j, '] => ', a[i, j]);
         end;

     for i := 1 to 5 do
         for j := 1 to 5 do
             if (a[i, j] mod 2 = 0) then a[i, j] := 30;

     writeln();

     for i := 1 to 5 do
         for j := 1 to 5 do
              writeln('[', i, ',', j, '] => ', a[i, j]);
end.

Для второго не понял, как решать ._.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?