В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
паксуха
паксуха
15.11.2022 21:44 •  Информатика

Мне ! решить 2 по ивт в паскале: 1)составить программу вычисления в массиве a(n) произведения нечетных элементов 2)составьте программу вычисления в массиве b(n) максимального среди отрицательных элементов и его номера. заранее огромное ! нужно!

Ответ:
Zlata2828
Zlata2828
21.06.2020 12:03
Var a: array [0..10] of integer;
    i, m: integer;
begin
     m := 1;
          for i := 0 to 10 do
     begin
          a[i] := random(50) - 25;
          writeln('[', i, '] => ', a[i]);
     end;

     for i := 0 to 10 do
         if (a[i] mod 2 = 1) then m := m * a[i];
     writeln(m);
end.

2)
var a: array [0..10] of integer;
    i, m: integer;
begin
     for i := 0 to 10 do
     begin
          a[i] := random(50) - 25;
          writeln('[', i, '] => ', a[i]);
     end;
          for i := 0 to 10 do
         if ((a[i] > a[m]) and (a[i] < 0)) then
            m := i;

     writeln('[', m, '] => ', a[m]);
end.

Можно и меньше циклов, это я для наглядности, чтобы всё не смешивалось =)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?