В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
YaroslavShevchuk
YaroslavShevchuk
19.01.2022 04:34 •  Информатика

Составить программу, решающую следующую : вы продавец, и у вас имеются гири весом 1, 2, 5 кг. наберите минимальное количество гирь для взвешивания n кг.язык программирования-паскаль

Ответ:
Var N, a, b: integer;
begin
     readln(N);
     a := N div 5;
     N := N mod 5;
     b := N div 2;
     WriteLn(a, 'x5, ', b, 'x2, ', N mod 2, 'x1');
end.

Вот так, делением можно)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?