В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sanfirovngmail
sanfirovngmail
06.11.2020 04:56 •  Информатика

Написать программу вычисления суммы всех 3-х значных чисел, у которых сумма цифр кратно числу а.нахождения суммы цифр 3х значного числа написать подпрограмму. ( с функцией) i = от 100 до 999 i=326 x = i div 100 y=i div 10 mod 10 z= i mod 10 s= x+y+z 2)определить значение переменной после выполнения фрагмента алгоритма: s: =24; m: =3456; while s> 10 do begin m: =m mod 10; s: =s-m end; s: =s+m; write(m); мне нужно именно решение, а не тупо !

Ответ:
Nazerke0606
Nazerke0606
21.06.2020 06:27
Function T1(b:integer):integer;
begin
T1:=b mod 10 +(b div 10)mod 10+((b div 10)div 10)mod 10;
end;
Var
i,a,S:integer;
begin
S:=0;
For i:=100 to 999 do
  if T1(i) mod 3 =0
  then S:=S+T1(i);
writeln(S);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?