В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Криш7771
Криш7771
03.10.2022 12:17 •  Информатика

Turbo pascal в прямоугольном треугольнике известны 2 катета, их значения вводятся с клавиатуры.вычеслить и вывести на экран sin, cos, tg, ctg. , составить программу.

Ответ:
Эхорит
Эхорит
21.06.2020 03:51
Var a, b, c: real;
begin
     readln(a, b);
     c := sqrt(sqr(a) + sqr(b));
     writeln('sin a = ', b / c);
     writeln('cos a = ', a / c);
     writeln('tg a = ', b / a);
     writeln('ctg a = ', a / b);
     writeln();
     writeln('sin b = ', a / c);
     writeln('cos b = ', b / c);
     writeln('tg b = ', a / b);
     writeln('ctg b = ', b / a);
end.

Вот так)) Удачи тебе)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?