В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
StepanEgorov
StepanEgorov
13.10.2022 09:41 •  Информатика

Составьте программу на языке паскаль для следующих : 1. найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. найдите среднее арифметическое всех целых чисел от a до b (значение aи b вводится с клавиатуры; a≤b). 3. дана последовательность вещественных чисел a1, a2, …, a15, по возрастанию, и, число n, не равное ни одному из чисел последовательности и такое, что a1≤n≤a15. a) определить сумму элементов последовательности меньших n. б) найти два элемента последовательности (их порядковые номера и значения) в интервале между которыми, находится число n.

Ответ:
viakobchuk
viakobchuk
01.10.2020 11:11
Var i, a, s: integer;
begin
     readln(a);
     for i := a to 500 do
         s := s + i;
     writeln(s);
end.

2) 
var i, a, s, c, b: integer;
begin
     readln(a, b);
     for i := a to b do
     begin
         s := s + i;
         c := c + 1;
     end;
     writeln(s / c:4:2);
end.

3)
const N=10;
var i, b, s: integer;
    a: array [0..N] of integer;
begin
     readln(b);
     for i := 0 to N do a[i] := random(9000);
     for i := 0 to N do
         if (a[i] < b) then s := s + i;
     for i := 0 to N - 2 do
         if (a[i+1] = b) then writeln('(', a[i], '; ', a[i+2], ')');
     writeln(s);
end.

=)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?