В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Таксман
Таксман
05.01.2022 03:46 •  Информатика

Напишите программу на Паскале, заполнив массив с генератора случайных чисел в диапазоне [-50; 50]. Дан целочисленный двумерный массив, размерности n x m. Найти сумму и произведение элементов, кратных 4 и 7. ​

Ответ:
SirErikBoss
SirErikBoss
24.06.2021 20:40

const

 n=5;

 m=6;

var

 a : array [0..n, 0..m] of integer;

 sum, pr, i, j : integer;

begin

 randomize;

 sum:=0;

 pr:=1;

 for j:=0 to m-1 do begin

   for i:=0 to n-1 do begin

     a[i,j] := random(100) - 50;

     if (a[i,j] mod 4 = 0) and (a[i,j] mod 7 = 0) then begin

       sum:=sum+a[i,j];

       pr:=pr*a[i,j];

     end;

     write(a[i, j], '  ');

   end;

   writeln();

 end;

 writeln('');

 writeln('Сумма = ',sum);

 writeln('Произведение = ', pr);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?