В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
i942627
i942627
23.05.2021 18:28 •  Информатика

Решить в Напишите программу, которая вводит натуральное число N и выводит на экран все нату-ральные числа, не превосходящие N и делящиеся на каждую из своих цифр

Ответ:
Викусик11112234556
Викусик11112234556
23.06.2021 09:57

n = int(input())

for i in range(1, n):

   flag = True

   for k in str(i):

       try:

           if i % int(k) != 0:

               flag = False

       except:

           flag = False

   if flag == True:

       print(i)

возможно можно проще))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?