В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kublahan
kublahan
18.03.2020 17:53 •  Информатика

Написать программу на Паскале Дан массив A целых чисел, содержащий 30 элементов. Вычислить и вывести сумму
тех элементов, которые нечетны и отрицательны.

Ответ:
urasaya
urasaya
21.06.2021 23:54

const

 n=30;

var

 a:array [1..n] of integer;

 i,sum:integer;

begin

 sum:=0;

 for i:=1 to n do

   begin

     a[i]:=random(101)-50;

     if (abs(a[i] mod 2) = 1) and (a[i]<0) then

       sum:=sum+a[i];

     write(a[i]:4);

   end;

 writeln;

 write('sum: ',sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?