В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
VeRa2KoToVa1
VeRa2KoToVa1
27.05.2022 15:16 •  Информатика

Паскаль. Используя оператор цикла с постусловием, составить программу вычисления суммы с заданной точностью:


Паскаль. Используя оператор цикла с постусловием, составить программу вычисления суммы с заданной то

Ответ:
sergeenkoandre
sergeenkoandre
21.06.2021 18:40

Объяснение:

const eps = 0.0001; // Точность

var

  denom, step: integer;

  s, s1: real;

begin

    {Начальные значения}

    s := 1;

    s1:= 1;

    denom := 1;

    step := 3;

    // Вычисление суммы

    repeat

        s1 := s;  // Сохранить предыдущее значение

        denom := denom + step; // Увеличить знаменатель

        if (denom mod 2) = 0 then

           // Если четный знаменатель, вычитаем

           s := s - 1/denom

        else

            // Если нечетный знаменатель, складываем

            s := s + 1/denom;

    until (abs(s - s1) <= eps); // Проверка на точность

   // Вывод в консоль

    writeln('s =', s : 10: 8, '  s1 =', s1 : 10: 8, '  denom =', denom:10);

    readln();  // удержимаем консоль

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?