В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Bisspector
Bisspector
19.08.2022 15:21 •  Информатика

Написать программу в с++ даны натуральные числа , действительные числа . вычислить (n1x1+) / (n1+)

Ответ:
танюша237
танюша237
20.06.2020 18:55
#include "stdio.h"#include "iostream"
using namespace std;
int main()
{
int n[20], x[20], amount1 = 0, amount2 = 0;
for (int i = 0; i < 20; i++)
{
cin>>n[i]>>x[i];
amount1 += n[i]*x[i];
amount2 += n[i];
}
int res = amount1 / amount2;
cout<<res; return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?