В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
soloviovav82owjd2t
soloviovav82owjd2t
28.04.2020 01:41 •  Информатика

Надо составить программу на паскале, которая будет писать все положительные значения f(x) на интервале от a до b с шагом h. Функция F(x) = 2cos(x)-1


Надо составить программу на паскале, которая будет писать все положительные значения f(x) на интерва

Ответ:
kennysussus
kennysussus
20.06.2021 19:41

Program trig;

var a,b,H:real;

Function F(n:real):real;

begin

F:=2*cos(n)-1;  

end;

begin

write('Введите шаг: ');

readln(H);

write('Введите интервал: ');

readln(a,b);

writeln('x    F(x)');

writeln('');

while a<=b do begin

 if(F(a) > 0) then writeln(a:0:2,'  ',F(a):0:2);

 a:=a+H;

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?