В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
petryskakate2003
petryskakate2003
12.01.2020 07:57 •  Информатика

Написать программу, используя цикл с параметром (for), для вычисления суммы: S=1+1/2+1/3+1/4++1/n

Ответ:
mehili
mehili
20.06.2021 06:29

c++

#include <iostream>

using namespace std;

int main() {

double s = 0; int n;

cin >> n;

for (int i = 1; i < n + 1; i++)

 s += 1. / i;

cout << s;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?