В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DaniilF3001
DaniilF3001
02.04.2022 14:21 •  Информатика

, написать программу по информатике! Определить сколько можно купить арбузов за 1000 рублей.
Цена арбуза (1кг) - 15 руб.,
Вес (Random, Т.е. программа с Randomize) - от 2 до 8 кг.
Желательно, чтобы программа была правильной, если сверятся с программы Паскаля.

Ответ:
LoviLopatu
LoviLopatu
19.06.2021 23:38

var a,b,c:integer;

begin

c:=0;

while b<1000 do begin

c:=c+1;

a:=random(2,8);

b:=b+a*15;

if b>1000 then

c:=c-1;

end;

writeln('можно купить ',c,' ШТ')

end.

0,0(0 оценок)
Ответ:
19283746521
19283746521
19.06.2021 23:38

Что-то вроде такого? Раз для каждого вес рандомный


, написать программу по информатике! Определить сколько можно купить арбузов за 1000 рублей. Цена ар
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?