В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

На языке ПАСКАЛЬ 1. Составить программу, которая сформирует двумерный массив, состоящий из 3-х строк и 4-х столбцов из целых случайных чисел из интервала (-50;50) и выведет на экран в виде таблицы.

2. Составить программу, которая сформирует одномерный массив из 10 целых случайных чисел из интервала (-20;20), определит сумму всех элементов массива, найдет максимальное и минимальное значения.

Ответ:
Ffffffsusjbshjxj
Ffffffsusjbshjxj
19.06.2021 22:23

1)

Program z1;

var i,j:integer;

a:array[1..3,1..4] of integer;

begin

for i:=1 to 3 do begin

 for j:=1 to 4 do begin

   a[i,j]:=random(101)-50;

   write(a[i,j]:5);

   end;

   writeln();

 end;

end.

2)

Program z2;

var i,j,max,min,sum:integer;

a:array[1..10] of integer;

begin

min:=1000;

for i:=1 to 10 do begin

 a[i]:=random(41)-20;

 print(a[i]);

 sum:=sum+a[i];

 if(a[i] > max) then max:=a[i];

 if(a[i] < min) then min:=a[i];

 end;

writeln();

writeln('Сумма: ',sum);

writeln('Максимальное: ',max);

writeln('Минимальное: ',min);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?