В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Анжела921
Анжела921
06.12.2022 11:29 •  Информатика

В Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 9. Программа получает на вход числа в последовательности, ввод чисел осуществляется до тех пор, пока не будет введён 0. В последовательности всегда имеется число, оканчивающееся на 9.
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.
Программа должна вывести одно число: количество чисел, оканчивающихся на 9.
Пример работы программы:
Входные данные
19
29
24
0
Выходные данные
2​

Ответ:
kistoria
kistoria
17.06.2021 21:19

s = 0

for i in range(0, 1000):

    a = input()

    if int(a) != 0:

        if str(a[-1]) == '9':

            s += 1

        if int(a) >= 30000:

            print('Слишком большое число!')

    else:

        break

print(f'Всего чисел: {s}.')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?