В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
elenabradulina
elenabradulina
27.08.2022 18:14 •  Информатика

: Дан массив из 50 случайных чисел на отрезке (x; y), отсортировать получившийся массив. Написать программу решения задачи.

Ответ:
sanay06
sanay06
15.06.2021 20:01

Язык — Java.

//Создание класса Scanner

import java.util.Scanner;

public class Bubble {

  public static void main(String args[]) {

//Обьявление переменных для ввода диапазона

int first, second;

//Заполнение массива 50 элементами

int[] array = new int[50];

//Создание обьекта класса Scanner, дла дальнейших вводов пользователя

Scanner input = new Scanner(System.in);

System.out.println("Write the first border of the range: ");

first = input.nextInt();

System.out.println("\nNow, write the second border: ");

second = input.nextInt();

//Обьявление индексной переменной i — идущей до самого последнего элемента в массиве array

for (int i = 0; i < array.length; i++) {

//Заполняем массив рандомными числами, начиная и заканчивая с диапазона, который ввёл пользователь

   array[i] = ((int)(Math.random() * ((second-first))-second)*(-1));

}

//Сортитовка пузырьком

 for (int i = 0; i < array.length; i++) {

//Новая индексная переменная j, которая в дальнейшем будет проверять, ни меньше ли неё следующая цифра

           for (int j = 0; j < array.length - i - 1; j++) {

//Проверка

               if (array[j] > array[j + 1]) {

//Обмен значениями между  не сортированными элементами

                   int temp = array[j];

                   array[j] = array[j + 1];

                   array[j + 1] = temp;

               }

           }

       }

System.out.println("\nSort an array with a bubble: ");

//Вывод всех уже отсортированных элементов

       for (int i = 0; i < array.length; i++) {

           System.out.print(array[i] + ", ");

       }

  }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?